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INSTRUCTIONS FOR USE—WARNING

This product is conform to the 89/336/EEC Directive. It complies with the ITE EN55022 standard for
EMC emissions and generic 50082-1 (1992 edition) immunity standards.

This product is an FCC Class-A apparatus. In a residential environment, it may cause
radioelectrical disturbances.

In addition, this programming board is not contained in an outer casing; consequently, it cannot be
immune against electrostatic discharges (ESD). It should therefore be handled only in static safe
working areas. Please refer to Appendix: EMC Conformity and Safety Requirements on page 15 for
relevant safety information.

USE IN LIFE SUPPORT DEVICES OR SYSTEMS MUST BE EXPRESSLY AUTHORIZED.

STMicroelectronics PRODUCTS ARE NOT AUTHORIZED FOR USE AS CRITICAL COMPONENTS IN

LIFE SUPPORT DEVICES OR SYSTEMS WITHOUT THE EXPRESS WRITTEN APPROVAL OF
STMicroelectronics. As used herein:

1. Life support devices or systems are those
which (a) are intended for surgical implant into
the body, or (b) support or sustain life, and whose
failure to perform, when properly used in
accordance with instructions for use provided
with the product, can be reasonably expected to
result in significant injury to the user.

2. A critical component is any component of a life
support device or system whose failure to
perform canreasonably be expected to cause the
failure of the life support device or system, or to
affect its safety or effectiveness.



Chapter 1:

11
1.2
13

Chapter 2:

2.1
2.2
2.3

Chapter 3:

3.1

3.2

Appendix:

Product Support

Contact List
Software updates

Table of Contents

Introduction .. ....... ... . 5
OVEBIVIBW ..ttt e e e et e e et ettt er et e e e e se e e e e eeeeseennnns 5
Hardware fEALUIES ......oouuiiii i 6
SOftWAre FEALUIES ....oeeiiiiiiie e e e e e e aanee 6
Getting Started . ...... ... 7
Delivery CheCKIiSt ........oooiiiiiiie et 7
Setting UP the EPB ..ottt 7
Installing the SOMWAIE ... e e 8
How to Program . .... ... .. 9
Programming MethodS ..........ouiiiiiiiiiiiii e 9
3.1.1 Installing a device for programming with the ZIF sockets ............... 9
3.1.2 Installing a device for programming using ISP mode ................... 10
A typical programming SESSION ....cccccvceevviiiiieeeiiiie e e ee i e e e e e e 11
EMC Conformity and Safety Requirements  ................ 15
................................................. 17
Getting prepared before you Call.........c.uoiiiiii i 17
............................................................................................................... 17
...................................................................................................... 18

3/20

3




4/20

Table of Contents




ST7 EPB User Manual 1 - Introduction

1.1

Note:

3

INTRODUCTION

Overview

The ST7 EPB is a programming board kit which allows you to program ST7
microcontrollers having EPROM, EEPROM and FLASH memories.

Figure 1: Typical ST7_EPB programming board

The layout of the programming board included in your ST7 EPB kit varies
depending on the type and package of the ST7 microcontroller you wish to
program (a typical example is shown in Figure 1). However, the general
programming procedure explained in this book remains the same for all boards.

A complete listing of the ST7 family of programming boards, with a summary of the
devices they support is given in ST7_EPB.pdf , available on the MCU on CD CD-
ROM.

The ST7 EPB is meant to program small numbers of microcontrollers (i.e. prototypes in the
development stage). For mass production programming, it is recommended that you use the
appropriate gang programmetr.

The programming board is linked via the parallel port, to a host PC running the
Windows Epromer software (WINEE). This software interface allows you to
customize and control the programming.
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Hardware features

A range of programming boards allow you to program all of the EPROM, EEPROM
and FLASH versions of the ST7 family. In Situ Programming (ISP) is also available
for the newer EEPROM devices.

Software features

A host PC running the Windows Epromer software (WINEE) is the control interface
for the ST7 EPB.

WINEE is a graphical Windows" interface that lets you:

Read, view, edit and save executable files in the Intel” HEX and Motorola” S19
formats, generated by the Assembler, Linker or C Compiler for ST
microcontrollers.

Program executable files into ST microcontrollers.
View and verify a microcontroller’'s memory contents.

Either create a project that defines how to program the microcontroller(s) or
load the files whose contents you want to program and then execute the
program.

WINEE includes a detailed online help utility.
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GETTING STARTED

Delivery checklist

Check that your ST7 EPB kit contains the following:

e 1 ST7 EPB Eprom Programming Board (i.e. the EPB appropriate to the sales
type ordered).

e 1 power supply.

e 1 parallel cable.

e 1 MCU on CDCDROM containing the windows" Epromer software.

* 1 10-pin HE10 type ribbon cable for ISP mode (if provided on the programming
board for the sales type ordered).

Setting up the EPB

To set up the ST7 EPB hardware, follow these instructions:
1 Shut down and power-off the host PC.

2 Connect one end of the supplied parallel cable to connector P1 of the ST7 EPB
and the other end to one of the host PC’s parallel ports (LPT1 or LPT2).

Be sure to use the parallel cable provided with your kit—using a longer parallel cable may
cause malfunctions.

Connect the cable directly between the host PC and the programming board—the insertion of
additional cables or switch boxes between the host PC and the programming board may
cause malfunctions.

Ifa dongle (a hardware key required by some software packages) is already connected to the
PC’s parallel port, it should not interfere with the programming board. However, if a
malfunction of the board should occur, please remove the dongle and restart the above
sequence.

3 Power on the programming board by connecting the power supply to the
programming board and to the mains. Ensure that the power supply is adapted
to the mains voltage and outlet type used in your country.

The board can be supplied from the integrated power supply provided with the board, or from
an external +15 Vpc /0.5 A power supply.

4 Power on the host PC and install the software provided as described in the next
section.
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Installing the software

Your ST7 EPB comes with the MCU on CD CD-ROM which contains a number of
ST7 software tools. These tools are compatible with Windows" 95, 98, 2000 and
Windows" NTH operating systems.

Windows~ 2000 and NT" users must have administrator privileges to install the Windows
Epromer.

To install and setup the ST7 software tools, follow these steps:

1
2

Close all other open applications on your Windows desktop.

Insert the MCU on CD into your CD-ROM drive. The CD-ROM'’s autorun feature
will open up a welcome screen on your PC. If the autorun feature does not work,

use Windows" Explorer to browse to the CD-ROM'’ s root folder, and double-
click on Welcome.exe .

Select Install Your Development Tools from the list of options. A new screen
will appear listing the different families of STMicroelectronics MCUSs.

Use your mouse to place the cursor over the ST7 Tools option. Choose
ST Tools, then ST7 Toolchain from the lists that appear.

The install wizard will be launched. Follow the instructions that appear on the
screen.

You can choose to install the complete toolchain (i.e. the appropriate version of
STVD7, the Windows Epromer and the Assembler-Linker) for each type of
development tool (Development Kit, HDS2 or EMU3 emulators or simulator), or
perform a customized installation.

If you choose a customized installation, you can choose to install only the
Windows Epromer (WINEE).

The installation is now complete. You will be prompted to reboot your computer.
You should do so before launching the Windows Epromer (described in Chapter 3:
How to Program on page 9).
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HOW TO PROGRAM

Programming Methods

Your ST7 EPB programming board is provided with at least one Zero Insertion
Force (ZIF) socket which allows the programming of packaged MCUs. In addition
to classic MCU programming using ZIF sockets, some of the newer EEPROM
memories can be programmed using the In Situ Programming (ISP) mode. ISP
mode allows the ST7 program memory contents to be updated using a standard
ST7 programming tool after the device is mounted on the application board.

Here we describe how to connect your device for programming using these
methods.

Installing a device for programming with the ZIF sockets

This section gives general guidelines on how to insert a device you wish to
program into the ZIF sockets on the programming board.

The online help for the Windows Epromer includes programming board layouts for
all of the ST7 EPBs.

1 Set up the EPB as described in Section 2.2 on page 7.
2 Make sure that your EPB is powered off.

3 From your host PC select Start>Programs>ST7 Tool Chain> Development
Tools>Windows Epromer to launch the Windows Epromer software program.
From the main menu bar, select Help>Hardware .

4 Alist of ST7TMDTx and ST72xx programming boards will appear in the online
Help window. Scroll down until you find your programming board model, and
click on it.

5 Using the board layout that appears for your programming board, identify the

ZIF socket for your device package on the programming board.
Take care when placing the device into a socket so as not to damage the device or the board.
Forcing the MCU into the socket may result in damage to the socket.
Never insert or remove devices when the programming board is powered. Devices are
powered only during read or write operations.
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7

Lift the relevant ZIF socket lever and place the device into the socket with pin 1
matching the mark on the board. Lock the device in place by lowering the lever
again.

Place your device here, making sure to
align pin 1 on the device with the arrow
on the programming board

ZIF Socket

lever

Power on the EPB.

Installing a device for programming using ISP mode

To see whether programming in ISP mode is possible for your target MCU, refer to
the MCU'’s datasheet, or consult ST7_EPB.pdf , installed with the Windows
Epromer, and available by selecting Start>Programs>ST7 Toolchain>User
Manuals .

If ISP mode is supported, the datasheet will provide the connection information
necessary to set up your application board for ISP programming.

Once you have ensured that you have correctly set up your application board to
support ISP mode, and that the ST7 EPB programming board is a type that
supports ISP mode, follow these instructions:

1
2
3

Set up the EPB as described in Section 2.2 on page 7.
Make sure that your EPB and application board are powered off.

From your host PC select Start>Programs>ST7 Tool Chain> Development
Tools>Windows Epromer to launch the Windows Epromer software program.

Connect one end of the ISP ribbon cable to the 10-pin ISP connector on the
EPB and the other end to the same type of connector on your application board.

Switch on your application board.

Power on the EPB.
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3.2 A typical programming session

The following instructions describe how you would typically program an ST
microcontroller using Windows Epromer. Note that this is not the only way to
program an ST microcontroller using Windows Epromer; for more information on
how to use the Windows Epromer, click the Help command in the main menu bar.

1 Make sure that the microcontroller you want to program is correctly connected
for programming, either via the ZIF socket or in ISP mode.

2 In the Windows Epromer window, from the main menu, select
Configure>Configure EPROMER . The epromer configuration dialog box is
displayed:

TFMDT1-KIT
TIMDT2-KIT
TIHDTA-KIT
T/MDT1-EPB
T/MDT2-EPB
T/MDT1-EPB2
TiMDT2-EPB2

T/MDT4-EPB
T/MDT5-EPB
T/MDTG-EPB2
T/HMDT/-EPB2

3 In the Select Hardware and Port tab of the Epromer Configuration window,
choose the programming device you are using from the list and the host PC
parallel port to which itis connected (i.e. LPT1 or LPT2).

4 Click on the Select Chip tab of the Epromer Configuration window.

3
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The list box shown below appears.

Epromer Configuration

T72411
172411-I15FP
T72411-I5P/S5C

Select your

target device

with the ISP

option if you

wish to

program your
target device
using In Situ
Programming
(ISP)

The following table list the suffixes which may appear following device names in
the Select Chip tab of the Epromer Configuration window, with the memory type
associated with each suffix and a comment describing the significance of the suffix:

Associated

Suffix Comment
memory type

ISP EEPROM If you select a ST72xxx-ISP device then you can program
using the In Situ Programming (ISP) mode. ISP mode
allows the ST7 program memory contents to be updated
using a standard ST7 programming tool after the device is
mounted on the application board.

12/20
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Suffix Comment

Associated
memory type

SO
S1
S2

FLASH With Windows Epromer you can perform READ, PRO-
GRAM and BLANK functions on specific sectors of certain
FLASH devices. In Windows Epromer, some device names
are listed with a SO, S1 or S2 suffix; this suffix indicates
which sector of the FLASH memory space is accessible if
you select this device name. When the device name
doesn’t have a SO, S1 or S2 suffix, then access is to the
whole memory space. For example:

If you select a ST72Fxxx-S0 device, the READ, PROGRAM
and BLANK functions are performed only on sector O of the
FLASH memory space; the option bytes are not accessible.
Likewise for S1 and S2.

If you select a ST72Fxxx device, the READ and PROGAM
functions are performed either on all FLASH memory
space or on the option bytes. The BLANK function erases
and blank checks all FLASH memory space (sectors 0, 1
and 2), the option bytes are not erased.

From the list shown in the Select Chip tab of the Epromer Configuration
window, select the device to be programmed:

Click Apply to save your changes without closing the dialog box, or OK to save
your changes and close the dialog box.

You can also select a microcontroller type from the drop-down list in the toolbar.

7
8

10

11

In the Epromer main window, click on a tab (EPROM, EEPROM or Options)

From the main menu, select File>Open and type the name of, or browse to, the
file you want to load.

In the list of files, click the file holding the code you want to program.

Click OK. When the file is loaded, the information area displays file checksum
and global device checksum (global device checksum represents checksum
calculated without reserved area).

To program the other device memory areas, repeat steps 7 to 10 above, first
clicking the tab associated with the memory area (EPROM, EEPROM or
Options) you want to program.

To open a file you've used recently, click its name at the bottom of the File menu.
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12 FOR EPROM ONLY: From the main menu, select Verify>Blank Check to
check that the ST microcontroller memory has not already been programmed.
(You cannot perform a blank check on EEPROM memory).

The results of the check are displayed in the information area.
13 From the main menu, select Program>All to program and verify all tabs.

14 From the main menu, select Verify>All to check that the programing session
was successfully completed (that the file contents match those programmed
into the microcontroller memory).
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APPENDIX: EMC CONFORMITY AND SAFETY REQUIREMENTS

3

This programming board respects the EMC requirements of the European
guideline 89/336/EEC under the following conditions:

Any tester, equipment, or tool used at any production step or for any
manipulation of semi-conductor devices must have its shield connected to
ground.

All ferrites provided with the must be attached as described in the hardware
installation instructions of the relevant user manual(s).

Your programming board must be placed on a conductive table top, made of
steel or clean aluminum or covered by an antistatic surface (superficial
resistivity equal to or higher than 0.5 MQ/cm2), grounded through a ground
cable (conductive cable from protected equipment to ground isolated through a
1 MQ resistor placed in series).

All manipulation of finished goods must be made at such a grounded
worktable.

The worktable must be free of all non-antistatic plastic objects.

An antistatic floor covering grounded through a conductive ground cable (with
serial resistor between 0.9 and 1.5 MQ).

It is recommended that you wear an antistatic wrist or ankle strap, connected to
the antistatic floor covering or to the grounded equipment.

If no antistatic wrist or ankle strap is worn, before each manipulation of the
powered-on programming board, you must touch the surface of the grounded
worktable.

It is recommended that antistatic gloves or finger coats be worn.

It is recommended that nylon clothing be avoided while performing any
manipulation of parts.
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PRODUCT SUPPORT

If you experience any problems with this product or if you need spare parts or
repair, contact the distributor or ST sales office where you purchased the product:

Getting prepared before you call

Contact List

Note:

3

Collect the following information about the product before contacting ST or your

distributor:

1 Name of the company where you purchased the programmer Kit.

2 Date of purchase.

3 Order Code: Refer to the side of your programmer kit box. The order code will
depend on the region for which it was ordered (i.e. the UK, Continental Europe
or the USA).

4 Serial Number: The serial number is located on a label on the programming
board.

5 Target Device: The sales type of the ST7 microcontroller you are using in your

development.

For American and Canadian customers  seeking technical support the US/Canada is split
in 3 territories. According to your area, contact the following sales office and ask to be
transferred to an 8-bit microcontroller Field Applications Engineer (FAE).

Canada and East Coast

STMicroelectronics

Lexington Corporate Center

10 Maguire Road, Building 1, 3rd floor
Lexington, MA 02421

Phone: 781-402-2650

Mid West

STMicroelectronics

1300 East Woodfield Road, Suite 410
Schaumburg, IL 60173

Phone: 847-517-1890
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West coast

STMicroelectronics, Inc.
30101 Agoura Court
Suite 118

Agoura Hills, CA 91301
Phone: 818-865-6850

Europe

France (33-1) 47407575
Germany (49-89) 460060
U.K. (44-1628) 890800

Asia/Pacific Region
Japan (81-3) 3280-4120
Hong-Kong (852) 2861 5700

Sydney (61-2) 9580 3811
Taipei (886-2) 2378-8088

Software updates

You can get software updates from the ST Internet web site http://mcu.st.com. For
information on firmware and hardware revisions, call your distributor or ST using
the contact list given above.
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