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Important Notice 
Sunplus Technology reserves the right to change this documentation without prior notice.  Information provided by Sunplus 

Technology is believed to be accurate and reliable.  However, Sunplus Technology makes no warranty for any errors which may 

appear in this document.  Contact Sunplus Technology to obtain the latest version of device specifications before placing your 

order.  No responsibility is assumed by Sunplus Technology for any infringement of patent or other rights of third parties which 

may result from its use.  In addition, Sunplus products are not authorized for use as critical components in life support devices/ 

systems or aviation devices/systems, where a malfunction or failure of the product may reasonably be expected to result in 

significant injury to the user, without the express written approval of Sunplus. 
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1 General requirement 
 
1.1 Software Requirement 

The SUNPLUS unSP IDE 2.0A or later version development tool for windows version. 

 

1.2 Hardware Requirement 
1. IBM compatible personal computer (Parallel port or USB port is required). 

2. ICE Probe (DB25 x 1 or USB x 1). 

3. SPMC75F2413A EVM board x1.  

4. One AC to DC adapter for ICE and EVM board, the specification should be: 

- Output Voltage: DC 9V.  

- Output Current: DC 1.2A.  

5. View of SPMC75F2413A EVM Board is shown as follows: 

 

 
Figure 2-1 the real view of SPMC75F2413A EVM Board 
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2 Getting Start 
 

2.1 Introduction 
The ICE PROBE is connected through the parallel port or USB port to PC that runs the unSP IDE 

development tool. Connecting steps are listed below. SUNPLUS strongly recommends you to connect them 

according to following order. 

 
2.2 Installing The Hardware 

1. Turn off the PC; 

2. Insert parallel (USB) connector of ICE cable into PC parallel (USB) interface; 

3. Insert the other end of ICE cable into the ICE connector CON1 on the EVM board; 

4. Turn on the PC; 

5. Insert connector of DC 9V into J10 connector, and then turn on the DC 9V. 

 
2.3 SPMC75F2413A EVM Board Hardware Setup 

PC

SPMC75F2413A EVM Board

SUNPLUS
ICE PROBE

or USB PORT
PARALLEL PORT

 

Figure 2-1 SUNPLUS ICE Probe with SPMC75F2413A EVM Board 

 

2.4 Installing The Software  
The SUNPLUS unSP IDE V2.0A or later version is for an integrated development environment for 

SPMC75F2413A. Some features are project management, text edit, program compile, and debug 

capabilities. User could not only edit your program but also debug it by unSP IDE tool. The following steps 

could guide you to open a project and execute your program quickly. Certainly, By means of SUNPLUS 

unSP IDE development environment, User could develop program easily and efficiently. 

   

Step1: Insert the unSP development software into your computer CD-ROM driver. 

Step2: Manually, Run “Setup.exe” file to install the unSP IDE tool. 

Step3: After unSP IDE tool installed, you could click unSP IDE 2.0A or later version to execute unSP tool. 

Step4: From the main menu, choose File -> New. The following dialog box will appear. Click “project” to 

create a new project. 
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Figure 2-2 The Creation New Project Dialog Box 

 

Step5: Key-in the new project name and select a specify MCU body name as SPMC75F2413A you want to 

develop on EVM board, and click “finish”. The project which included both *.h and *.rc files was 

created. Finally, You still need to create a *.asm file or *.c to make the entry point for your project. 

The main() function is the default entry point in C language development environment.  

 
Figure 2-3 Selection of MCU body  

 

Step6: From the main menu, Choose File > New. Click “File” to create a new file. For example, new a C 

example file Example.c. 

Step7: After clicking “File”, the following dialog box will appear. 

 

You have nine kinds of files to choose. Choose “SP IDE C File” and key in file name, then click “OK”.   
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Figure 2-4 Creation file Dialog Box 

 
Step8: When step1 to step7 have already been executed, from the main menu, choose View -> 

Workspace. A window would be displayed as following picture. With selection Example.c on 

workspace, you could edit your source code on the right side of window. 

 

Figure 2-5 Edition session Started 
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Step9:  After finishing your source code, you could complier and linker your source code by following 

steps. 

Step10:  From the main menu, choose Build > Build all. The User interface would display the result of 

execution. 

Step11:  From the main menu, choose Build -> Start Debug -> Go. Your program would be downloaded 

to memory with associated address and executed.  

 

Congratulations! You have successfully completed this tutorial!  

You can continue to experiment with the unSP IDE interface. For an in-depth guide of all of the user 

interface features, select Help -> Help Topic for detail. 
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3 SPMC75F2413A EVM Boards Components 
 
3.1 Introduction 

 

The SPMC75F2413A EVM Board has the following hardware features: 

 The SPMC75F2413A Micro-controller can be on-chip programming the developer’s application software 

and debug in unSP IDE environment through the embedded ICE logic.  

 A standard connector for SUNPLUS Probe use. 

 A connector for DC power input 9V, 1.2A. 

 A push-button switch connected to reset MCU (S2). 

 Eight high-efficiency LEDS connected to GPIO IOD[7:0]. User could use the LED port to output status for 

indicating the MCU operating state. The LED output will be disabled by opening jumper JP8. 

 Six push-button switch connected to IOA[8:12, 15]. The default name are MODE, MOV, UP, DOWN, 

START and STOP which are useful for manually key input in inverter-based application. These signals can 

be disabled by opening the jumpers JP6.  

 A UART transceiver circuit connected to the ports IOC0/IOC1 or IOB12/IOB13 depending on jumper JP2 

settings. The MCU can communicate to PC with Hyper-terminal software. 

 The SPI pins, SDI, SCLK and SDO are connected to a four-digit display device. These signals can be 

disabled from opening the jumpers JP5.  

 A I2C eeprom circuit which are connected to IOB[14:15]. These signals can be disabled by opening the 

jumpers JP7.  

 The clock source can be selected either from crystal device or external oscillator. It can be done through 

the jumper JP1. 

 Two channels motor control and position input interface which are reserved at J1 and J2 connectors. The 

default fault input FTINx and overload input OLx will be pull to high by external resistors. 

 

This chapter will describe the major components on the SPMC75F2413A EVM board and hardware 

interface which connected to SPMC75F2413A chip. It includes the power circuit, EEPROM, IO expansion, 

encoder input interface, motor control interface, LED display, four-digit segment display, UART, key input 

and ADC interface. 
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3.2 SPMC75F2413A EVM Board Connectors Location 

CN10
CN4

CN5

J2

J1

JP5

CN9

CN8

CN7

CN6

JP1 JP4

JP8

JP6

JP7

JP2

CN1 CN2

P1

JP3

CN3

 

Figure 3-1 Connectors Location of SPMC75F2413A EVM Board 
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3.3 Power 
Figure 3-2 shows the power circuit of EVM board. The input is from 9V adapter and rectified by diode bridge 

D1. The output is connected to a regulator LM7805 and supply +5V voltage to whole EVM board. The 3.3V 

is output from a simple zener voltage clamp circuit. 
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N
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0.1uF

+5V
+5V

D5
3.3V
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+3.3VR10 75
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104

CN4

GND
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2
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4
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Power
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+5V
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470uF

-
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DIODE BRIDGE

2

3

1

4
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LED

1
2

CN10

GND

1
2
3
4
5

R2

330+ C1

470uF

S1 SW 2P2T

2
1

3

5
4

6

CN3

Power

1
2
3

 

Figure 3-2 Power circuit of EVM board 

 

3.4 EERPOM 
The EEPROM storage circuit is shown in Figure 3-3. It consists of a 4K byte EEPROM AT24C04 and 

communicate with SPMC75F2413A by using I2C protocol. The SPMC75F2413A use software and polling 

method to simulate I2C protocol and access the data of EEPROM. The EEPROM access signal will be 

disabled by opening jumper JP7. 

+5V

JP7

EEPROM

1 2
3 4

EEPROM

IOB14

R43
4.7K

IOB15

R42
4.7K

R44
4.7K

C31

0.1uF
IC9

24C04

1
2
3
4

8
7
6
5

A0
A1
A2
GND

VCC
WP

SCL
SDA

 

Figure 3-3 I2C EEPRM data storage circuit 

 

3.5 I/O Expansion 
The I/O expansion circuit is shown in Figure 3-4. The I/O ports are expanded to connecter CN6, CN7, CN8 

and CN9 which represents the GPIO port A, B, C and Dm, respectively. User can use the expansion ports 
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to connect other application circuits and can also measure the signal on I/O port.   
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Figure 3-4 I/O expansion circuit 

3.6 Encoder Input Interface 
There are totally two encoder input interface on SPMC75F2413A which named as phase counting input. 

The EVM board has one encoder input connector CN5. Use IOA13 and IOA14 as two quadature encoder 

pulse input signal which are the phase A and phase B. And the IOC5 pulse input (phase Z) is used to clear 

the encoder counting value. 

QEAIOA13
IOA14+ C23

47uF

+5V

IOC5
C25
0.1uF

CN5

QEV

1
2
3
4
5

 

Figure 3-5 Encoder input circuit 

 

3.7 Motor Control Interface 
The connector J1 and J2 are reserved for motor control applications. Each connector is the expansion port 

for MCP and PDC timer which consists of PWM output pins and position input pins. The external fault input 

pins and overload input pins are pull to high level by external resistors.  
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Figure 3-6 Motor control interface circuit 

 

3.8 LED Display 
There are eight LED display on EVM board. The LED display is shared the low eight bits of GPIO port D. 

The LED display can be disabled by opening jumper JP8. 

R45 470
IOD2

R38 470

IOD7

D8 LED
1 2

LED

D7 LED
1 2

R48 470 D14 LED
1 2

IOD1

IOD4

R40 470

R46 470

D13 LED
1 2

JP8
LED 1

2

D9 LED
1 2

D12 LED
1 2

IOD3

IOD5

IOD6

R39 470

R47 470

D11 LED
1 2

D10 LED
1 2

R41 470

IOD0

 

Figure 3-7 LED display circuit 

 

3.9 Four-Digit Segment Display 
The four-digit segment display circuit is shown in Figure 3-8. The circuit uses two 74HC595 to transmit 

serial data and latch data to display information. The SPMC75F2413A uses SPI interface to transmit serial 

data to 74HC595 and use IOB12 to latch the data. All of digit selection signal and LED segment selection 

signal are all active low. The SPMC75F2413A first transmit high byte digit selection value then low byte 

segment selection value. Figure 3-9 shows the transmit timing. The signals SER, SRCLK and RCLK will be 

disabled when opening jumper JP5. 
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Figure 3-8 Four-digit segment display circuit 

 

 

Figure 3-9 Serial data transmit timing 

3.10 UART 
The SPMC75F2413A EVM Board has on-board UART transceiver circuit which the receive and transmit 

signals can be either from IOC0/IOC1 and IOB12/IOB13. The UART serial port P1 can be used to 

communicate the hyper-terminal software on the host PC. Table 3-1 shows the UART transceiver path 

selection of SPMC75F2413A and Figure 3-10 shows the UART application circuit. 
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Figure 3-10 UART application circuit 

Table 3-1 UART transceiver signals selection  

Jumpers Location for TXD Location for RXD 

1-3, IOB13 forTXD (default) 2-4, IOB12 for RXD (default) 
JP2 

3-5, IOC1/TXD 4-6, IOC0 for RXD 

 

3.11 Key Input 
The key input circuit is shown in Figure 3-11. The circuit contains six push buttons and default states are at 

low level. When a key is pressed, the corresponding voltage level is raised to high level and can be 

detected as key-change event on SPMC75F2413A. The key input signals will be disabled when opening 

jumper JP6. 

JP6

Key

12
34
56
78
910

1112

IOA9

R37
10K

R36
10K

IOA10

S6
Down

S8
Stop

+5V

IOA11

R34
10K

S3
Mode

IOA12

Key
S5
Up

R35
10K

S7
Start

IOA8

IOA15

R33
10K

R32
10K

S4
Mov

 

Figure 3-11 Key input circuit 

3.12 Analog-to-Digital Converter 
The SPMC75F2413A has an on-chip, eight channels, 10-bit analog-to-digital converter (ADC) module. The 

voltage reference of ADC module is either AVDD (+5V DC) or external voltage reference. The jumper JP4 is 
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used to select the voltage reference source. When choosing external input as ADC reference voltage, the 

voltage reference should be connected to pin 2 and 3 of JP4 and opening JP4. 

+5VA

AVSS

WR1
5K

1
3

2C24
0.47uF

IOA0

JP3
WR1 2

C26
0.22uF

Analog

C28
0.1uF

AVSS

EXT_REF

+5VA
JP4

EX_REF

1
2
3+ C27

47uF

 

Figure 3-12 ADC circuit 

3.13 Clock Sources 
The SPMC75F2413A is a 16bit unSP microcontroller and operating speed is 24.0 MHz. The clock source 

can be either from a crystal or oscillator device. The clock path selection is from the jumper JP1. The table 

3-2 shows the configurations and default settings.  

Table 3-2 clock source selection – JP1 

Jumper location function 

1-2 (default) Crystal mode, crystal connected to XTAL2 
JP1 

2-3 Oscillator mode, crystal connected to XTAL2 

When user needs to change the clock source, it is also necessary to change the system option settings in 

P_System_Option register to match the changes of JP1. It can be done through directly modify the 

information window settings of unSP IDE environment as shown in Figure 3-13. 

 

Figure 3-13 Information window of SPMC75F2413A 
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4 Appendix 
 

4.1 SPMC75F2413A EVM Board Schematic 
 

SPMC75F2413A EVM board contains the following blocks: 
1. SPMC75F2413A MCU  

2. External reset circuit  

3. External crystal and oscillator circuit  

4. Four GPIO ports extension 

5. LED display and four-digit segment display circuits 

6. I2C AT24C04 EEPROM interface circuit 

7. UART interface circuit 

8. Motor control interface and encoder input connector 

9. ADC circuit 

10. Key input circuit 

11. USB/Parallel port probe connector 
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Figure 4-1 SPMC75F2413A EVM Board Schematic 
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4.2 Connectors Descriptions 
Connector Function Pin No. Function Descriptions 

P1 UART interface  - Standard DB9-F UART communication interface 

1 +3.3V 

2 ICE Probe enable signal (ICE_EN） 

3 ICE Probe serial clock output signal（ICE_CLK） 

4 ICE Probe serial data input/output signal（ICE_SDA） 

CN1 
ICE Probe 

Connector A 

5 GND 

1 +3.3V 

2 ICE Probe enable signal (ICE_EN） 

3 ICE Probe serial clock output signal（ICE_CLK） 

4 ICE Probe serial data input/output signal（ICE_SDA） 

5 GND 

CN2 
ICE Probe  

Connector B 

6 NC 

CN3 Power input - External 9V DC/AC input 

CN4 GND testing pads 1～5 GND 

1 +5V  

2 Phase A encoder pulse input 

3 Phase B encoder pulse input 

4 Phase Z pulse input for clear encoder counting value 

CN5 Encoder input 

5 GND 

CN6 IOA ports 1～16 IOA expansion ports：IOA0~IOA15 

CN7 IOB ports 1～16 IOB expansion ports：IOB0~IOB15 

CN8 IOC ports 1～16 IOC expansion ports：IOC0~IOC15 

CN9 IOD ports 1～16 IOD expansion ports：IOD0~IOD15 

CN10 +5V testing pads 1～5 +5V 

1、15、16 GND  

2～7 
MCP3 timer six channels PWM output：W1N、V1N、U1N、
W1、V1、U1 

8 
External fault input signal for protect MCP3 timer drive 
circuit:：FTIN1 

J1 Motor 1  

drive interface 

9 
Overload input signal for protect MCP3 timer drive 
circuit：OL1 
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Connector Function Pin No. Function Descriptions 

10、11 +5V 

12～14 Rotor position signal input：H1_U、H1_V、H1_W 

1、15、16 GND  

2～7 
MCP3 timer six channels PWM output：W2N、V2N、U2N、
W2、V2、U2 

8 
External fault input signal for protect MCP4 timer drive 
circuit:：FTIN2 

9 
Overload input signal for protect MCP4 timer drive 
circuit：OL2 

10、11 +5V 

J2 
Motor 2 

drive interface 

12～14 Rotor position signal input：H2_U、H2_V、H2_W 
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